Now that iOS 5.0.1 can be jailbroken untethered, users who rely on unlock tools such as GEVEY or Ultrasn0w can enjoy iOS 5.0.1 safer. If you rely on unlock tools you should always stay away from updating your firmware, even when untether jailbreak comes out for any firmware. This is because unlocking your iPhone depends on the baseband versions, not the iOS update version. So you must always wait to see if there’s any tool to preserve the baseband before updating.

Fortunately, redSn0w doesn’t only allows you to untether jailbreak iOS 5.0.1, it also can keep your current iPhone baseband when updating to iOS 5.0.1. To unlock iOS 5.0.1 you can either do it using GEVEY SIM or Ultrasn0w. But remember, you must have compatible basbeband versions to unlock an iPhone 4 using one those tools.

Unlocking iPhone 4 iOS 5.0.1 using GEVEY SIM:

If you want to use a GEVEY SIM to unlock your iPhone 4 make sure the iPhone has one of the GEVEY unlockable baseband: 1.59, 2.10, 3.10.1, 4.10.1. Then create a custom IPSW using redSn0w to preserve your baseband. For those using GEVEY Ultra still need t follow the process below because FuriousMOD is not compatible with IOS 5.

Gevey SIM iOS 5

1. Now to activate the GEVEY SIM on iOS 5.0.1, insert the GEVEY & SIM in your iPhone, turn it on.

2. Go to Settings.app, choose Phone, then select SIM Applications and then Instructions/English. A screen should pop up and click Accept.

3. Press the Home button,wait until the carrier status change from Searching to No Service. Open up the Phone.app and dial 112 for two or three seconds and hang up after calling.

4. Now go to Settings and turn Airplane Mode on then off; keep doing it until the carrier menu shows up.

The iPhone 4S should now be unlocked if you follow the steps correctly.

Unlocking iPhone 4, 3GS iOS 5.0.1 using Ultrasnow:

After updating to iOS 5.0.1 and keeping the old baseband you should be able to unlock without buying the GEVEY SIM by using Ultrasn0w, the free unlocking tool provided by the iPhone Dev Team. To unlock your iPhone using Ultrasn0w, the iPhone needs to have one of the compatible baseband:

  • iPhone 4 Ultrasn0w supported baseband: 01.59
  • iPhone 3GS: 04.26.08, 05.11.07, 05.12.01 and 05.13.04
Now if the iPhone has a supported baseband, go to Cydia and search for UltraSn0w, download it and install it. The iPhone 4/3GS should now be unlocked with UltraSnow.